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例題2. 三維廠房構架 
 

 

 

  概要 
 

此例題將介紹利用 midas Gen 建立廠房結構模型的步驟，以及進行分析和查看分

析結果的方法。 

 

在“例題1”中介紹了有關 midas Gen 介面操作的一些基本功能。本例題2中，除

了可以複習“例題1”所介紹的基本操作功能外，還可以學習一些其他十分有用的

進階操作功能。  

 

按照本例中的提示說明親自進行實際操作，可在短期內熟悉 midas Gen 建立鋼構

架廠房模型的基本技巧，達到事半功倍的效果。 

 

此例題的步驟如下： 

 

1. 開啟新檔並設定建模環境 

2. 輸入構件的材料和斷面資料 

3. 輸入節點和單元建立模型 

4. 輸入鋼構廠房的邊界條件 

5. 輸入各項載重 

6. 利用樹形選單查看模型資料的輸入狀況 

7. 執行結構分析 

8. 查看分析結果 
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材料種類：  A36 

斷面種類：   
1 : RH 440x300x11x
18 : 邊柱、屋頂主梁  

2 : RH 350x350x12x
19 

: 內柱 

3 : W 18×65 : 中間樓層主梁和小梁 

4 : CT 147x200x8x1
2 

: 側面桁架的上弦和下弦構件 

5 : WT 7×24 : 屋頂桁架的上弦和下弦構件 

6 : WT 4×9 : 屋頂桁架的垂直及對角(傾斜)構件 

7 : L 4×4×5/16 : 抗風斜撐 

分析模型與載重條件  

 

本例題廠房的幾何形狀、邊界條件以及所使用的構件如圖1所示。載重簡單按一般

廠房靜載重、活載重及風力等考慮（本例題資料僅供參考），載重組合可以在後處

理模式中輸入。 

 

 載重狀況 1 – 自重 Self Weight 

 載重狀況 2 – 中間樓層的靜載重 0.3 tonf/m2,  

    屋頂層靜載重 0.11 tonf /m2 

 載重狀況 3 – 中間樓層活靜載重 0.5 tonf /m2,  

 載重狀況 4 – 屋頂活載重 0.1 tonf /m2  

 載重狀況 5 – X方向的風力載重 0.88 tonf /m  (均佈線載重) 

 載重狀況 6 – Y方向的風力載重 0.92tonf  (節點力) 

 

 

 

 

 

 

 

 

 

 

 

 

圖1.  分析模型資料 
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    開啟新檔及設定基本操作環境  

 

選擇 File> New Project 選單（或者點擊 ）開啟新檔，若要存檔可選擇File> Save 

選單（或者點擊 ）並輸入檔案名稱。 

 

單位系統 

此例題使用的單位為 ‘m’ 和 ‘tonf’。 

 

1. 在主選單中選擇 Tools>Unit System 

2. 在 Length 選擇欄中選擇 ‘m’  

3. 在 Force(Mass) 選擇欄中選擇 ‘tonf (ton)’  

4. 點擊  鍵  

 

設定點網格 

 

網格（Grid）是為了方便使用者輸入節點或單元，在模型視窗上顯示的參考點或參
考線。 

 

可利用主選單 View>Grids> Point Grid 和 Line Grid 命令定義點網格和軸網。當同
時使用網格（Grid）與鎖點（Snap）功能時，滑鼠會自動捕捉到最近的網格上的點，
故使用起來非常方便。 

 

使用者可以單獨使用也可併用  Point Grid 和 Line Grid 功能。本例題主要使用
 Point Grid 功能。 

 

1. 主選單 Structure>UCS/Plan>Grids 點擊 Define Point Grid 定義點網格  

2. 在 dx , dy 輸入欄輸入 ‘1, 1’ 

3. 點擊  鍵  
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設定使用者座標系統（UCS）  
 

在“例題1”中已介紹將全球座標系(GCS)的X-Z平面設定為使用者座標系(UCS)的

x-y平面的方法。 

 

在本例題中，以建築物○A 構架（參見圖1）為標準構架立面延伸建模，為了方便建

立該構架柱與屋頂桁架的模型，首先將GCS的X-Z平面設定為UCS的x-y平面。 

 

    

1. 主選單 UCS>  X-Z  

2. 在 Origin 輸入欄內輸入 ‘0, 0, 0’  

3. 在 Angle 輸入欄內選擇 ‘0’  

4. 選擇 Change View Direction 修改視角 (‘’)  

5. 點擊  鍵  

 

 

圖2.  設定使用者座標系統 

 

UCS



  選擇 Change View 
Direction後點擊OK鍵，
模型視窗的視景就會自動
切換到設定的UCS平面。 

GCS 



 

 

 

 
三維廠房構架 

 

2-5 

   輸入構件的材料與斷面資料 
 

使用者可以隨時輸入構件的材料和斷面，無論是否已經建立了單元。但若要在建立

單元之間建立查看斷面資料的話，可以邊建模邊使用  Hidden 功能選擇顯示構

件的大小或形狀，極為方便有效率。 

 

在 樹形選單 的 Menu 表單選擇 Properties>Material Properties，建立新的材料和斷

面資料。 

 

本範例構件的材料和斷面資料如下。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

材料種類：  SS400 

 

斷面種類：   

1 : RH 440x300x11x18 : 邊柱 

2 : RH 350x350x12x19 : 內柱 

3 : RH 440x300x11x18 : 中間樓層主梁 

4 : RH 350x350x12x19 : 中間樓層小梁 

5 : RH 294x200x8x12 : 屋頂主梁 

6 : RH 250x250x9x14 : 屋頂桁架的上弦和下弦構件 

7 : CT 147x200x8x12 : 側面桁架的上弦和下弦構件 

8 : C 150x75x6.5x10 : 桁架的垂直及對角斜撐構件 

9 : 2L 90x125x10-19 : 抗風斜撐 
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圖3. 輸入的斷面資料 
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本例題所有構件的斷面均採用midas Gen內建的CNS91型鋼標準斷面。  

 

1. 在 樹形選單 的 Menu 表單中選擇 Properties>Material Properties 

2. 點擊  鍵  

3. 在 Material ID 輸入欄內輸入 ‘1’  

4. 在 Type of Design 選擇欄中選擇 ‘Steel’   

5. 在 Standard 選擇欄中選擇 ‘CNS06(S)’ 

6. 在 DB 選擇欄中選擇 ‘SS400’ 

7. 在 Name 欄內輸入 ‘鋼材’   

8. 點擊  鍵  

9. 選擇 Properties 對話視窗上方的 Section 表單 

10. 點擊  鍵  

11. 選擇 Section 對話視窗上方的 DB/User 表單 

12. 在 Section ID 輸入欄內輸入 ‘1’  

13. 在斷面形狀選擇欄內選擇 ‘I-Section’  

14. 在 DB 選擇欄中選擇 ‘CNS91’  

15. 在 Section 選擇欄選擇 ‘RH 440x300x11x18’  

16. 點擊  鍵  

17. 重複步驟 15 和 16，輸入 2~9 號斷面（參見圖3） 

18. 對於其他斷面形狀資料（T型斷面、C型鋼等）也按類似的方法輸入 

19. 最後選擇 ‘2L 90x125x10-19’ 後點擊對話視窗的  鍵 

20. 查看在選擇構件過程中是否有錯，之後點擊  鍵  

 

在已設定的UCS x-y平面上，利用 點網格 來佈置建築物○A 列上的單元。在樹形

選單的 Menu 表單選擇 Geometry>Elements>Create Elements，並按下列步驟建立

單元。 

 使用者可事先在Tools
 >Preferences中設定規範
預設值。 

 在Section 選擇欄輸入
構件名稱的第一個字母的
話，會自動顯示以該字母
為首的斷面列表，列表中
第一個斷面為該字母為首
的斷面中最重的斷面。  

 Name 是用來區分各種
材料的，與材料的性質無
關。在資料庫中選擇某種
材料時，名稱欄中會自動
被 賦 予 被 選 擇 的 材 料 名
字。 
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    使用節點和單元建立模型 

建立柱單元 

 

                      圖4.  建立柱單元 
 

1. 點擊圖示選單  Hidden  

2. 點擊圖示選單  Node Number,  Element Number  

3. 主選單 View>Grid 點擊  Point Grid Snap 

4. 主選單 Node/Element>Create Elements 

5. 在 Element Type 選擇欄中選擇 ‘General beam/Tapered beam ’ 

6. 在 Material 選擇欄中選擇 ‘1 : 鋼材’  

7. 在 Section 選擇欄選擇 ‘1 : RH 440x300x11x18’  

8. 在 Beta Angle 選擇欄中輸入 ‘ 0 ’  

9. 參照狀態列（圖4的）中的UCS座標，用滑鼠將點(0, 0, 0)和(0, 9, 0)、 

 (20, 0, 0)和(20, 9, 0)連接起來建立單元 1 和單元 2（邊柱） 

10. 接著在斷面名稱選擇欄選擇 ‘2 : RH 350x350x12x19’  

11. Beta Angle 選擇欄選擇 ‘ 90 ’ 

12. 以UCS為標準依次連接點(10, 0, 0)和(10, 9, 0)建立單元 3   

 

 如果建立單元後畫面的
位置和大小等不太合適，
可 利 用 Z o o m 或 P a n 功 能
（圖4的）對操作畫面作
適當調整。 

  可用滑鼠單擊 Nodal 
Connectivity 輸入欄之後進
行步驟12的操作。 
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建立屋頂桁架   
 

以下介紹在UCS的x-y平面上輸入屋頂桁架的方法。屋頂桁架的形狀雖然複雜，但

對這種標準規則的結構若利用 Structure Wizard 中的桁架建模精靈會非常有效。 

 

桁架建模精靈 Truss Wizard 由3個對話視窗構成，其功能如下。 

 Input 表單：指定桁架的大小和形態  

 Edit 表單：決定是否添加垂直構件並指定桁架各構件的材料和斷面 

 Insert 表單：將定義的桁架置入模型，指定其位置和佈置角度。 

 

桁架建模精靈能快速建立二維平面桁架，當利用 Truss Wizard 自動建立桁架時，

上下弦構件會被定義為梁單元，垂直構件和對角斜撐構件會被定義為桁架單元。 

 

首先點擊圖4 中 的  鍵，由主選單 Structure>Base Structures>Truss 執

行桁架建模精靈： 

 

(a) Input (b) Edit (c) Insert 

圖5.  桁架建模精靈 

 

 為了能夠更快、更
方便地對一些規則結
構進行建模，Gen提
供了多種形式的結構
建模助手： 

 

 

 Beam 
 Column 
 Arch 
 Frame 
 Truss 
 Plate 
 Shell 
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1. 點擊圖4 中 的  鍵  

2. 主選單點擊 Structure>Base Structures>Truss 

3. 在 Input 表單（圖5(a)- ）的 Type 選擇欄選擇屋頂桁架的形狀  

4. 在 Number of Panels （上下弦分割數）輸入欄輸入 ‘4’ 

5. 在 L（桁架的長度）輸入欄輸入 ‘10’ m 

6. 在 H2（桁架的高）輸入欄輸入 ‘2’ m 

7. 選擇 ‘Symmetric’ 考慮對稱形式  

 

 

1. 切換至 Edit 表單  

2. 在 Insertion 中勾選() Vertical 加入垂直桿 

3. 在 Material 選擇欄選擇 ‘1 : 鋼材’  

4. Top 上弦斷面選擇為 ‘6 : RH 250x250x9x14’   

5. Bottom 下弦斷面選擇為 ‘6 : RH 250x250x9x14’ 

6. Vertical 垂直桿斷面選擇為 ‘8 : C 150x75x6.5x10’  

7. Diagonal 對角桿件斷面選擇為 ‘8 : C 150x75x6.5x10’    

 

 

1. 切換至Insert 表單 

2. 在 Insert Point 輸入欄內輸入UCS座標 ‘0, 9, 0’，或者用滑鼠單擊輸入欄

後指定單元 1 的上部節點 2。 

3. 按 Beam End Release 的 Assign 按鈕取消所有梁端預設鉸接的束制條件 

4. 在 Origin Point 欄內選擇 ‘1 (0, 0, 0)’  

5. 點擊  鍵  

6. 點擊  Zoom Fit 

7. 點擊 Truss Wizard 對話視窗的  鍵 

 
 

  選擇Show Dimension
時，在L和H2中所輸入的
數值就會顯示在建模精靈
的模型視窗中（圖5(a)的
）。 

 當輸入結果和圖6不同
時，可點擊Undo 後在
桁 架 建 模 精 靈 中 重 新 輸
入。  

 利用Tab鍵可移動輸入
的位置，並直接輸入材料
和斷面編號。 

 選擇Show Element No.
時，在建模精靈的模型視
窗中就會顯示構件編號。 
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圖6.  完成屋頂桁架建模 
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建立中間層橫向主梁 

 

利用  Point Grid Snap 功能，在中間層的位置建立2支中間樓層主梁。 

 

1. 點擊圖示選單  Auto Fitting  

2. 點擊圖示選單  Front View  

3. 在功能目錄表（圖7的）中選擇 Create Elements  

4. 在 Section 選擇欄選擇 ‘3 : RH 440x300x11x18’  

5. 在 Beta Angle 輸入欄輸入 ‘0’  

6. 在 Intersect 交叉分割中選擇 Node 和 Elem （‘’標記）  

7. 用滑鼠單擊 Nodal Connectivity 輸入欄，使用滑鼠編輯功能 

8. 連接UCS座標系上點 (0, 3, 0) 和 (10, 3, 0) 建立第一支主梁。 

9. 連接UCS座標系上點 (0, 6, 0) 和 (10, 6, 0) 建立第二支主梁。 

 

 

圖7.  建立中間樓層主梁 

 在柱上的任一點連接
其他單元時，若利用交
叉分割選擇欄的Element
功能，會自動在相應節
點分割柱子構件。 
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建立三維構架 

 

利用所完成的二維立面構架，在GCS的Y方向以 8m 間距複製 2 個構架。   

 

首先將畫面轉換為三維狀態。為操作方便，在選擇被複製單元時先將中間層的2支
主梁先予以排除，對其另行複製。 

 

 

圖8-(a).  複製而成的兩個構架 

 

1. 主選單 View>UCS/GCS 點擊  GCS  

2. 點擊圖示選單  Iso View  

3. 點擊圖示選單  Select All  

4. 點擊圖示選單  Select Single 後，點擊中間層的主梁（單元 33, 36）

將其由複製對象中排除。 

5. 在功能目錄表（圖8-(a) 的）中選擇 Translate Elements  

6. 在 Mode 選擇欄中選擇 ‘Copy’  
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7. 在 Translation 選擇欄中選擇 ‘Equal Distance’ 

8. 在 dx, dy, dz 輸入欄輸入 ‘0, 8, 0’ 或利用滑鼠編輯功能自動輸入 

9. 在 Number of Times 輸入欄中輸入 ‘2’  

10. 點擊  鍵  

11. 若不想查看構件編號可點擊圖示選單  Element Number  

12. 點擊圖示選單  Shrink Element  

13. 點擊圖示選單  Select Single，用滑鼠選擇中間層的主梁（單元 33, 36） 

14. 在 dx, dy, dz 輸入欄輸入 ‘0, 8/3, 0’   

15. 在 Number of Times 輸入欄輸入 ‘6’ 

16. 點擊  鍵  

 

 

圖8-(b).  複製而成的三維構架 
 

  

   在midas Gen可以
將數字和計算式一同
輸入，並可使用大部
分的計算公式。 
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建立中間層縱向主梁 

 

如圖9所示，建立中間層與Y平行的縱向主梁。為了避免將現有的點網格和節點混

淆，需先將  Point Grid 和  Point Grid Snap 關閉。 

 

圖9.  建立中間層縱向主梁 

 

1. 主選單 View>Grid>  Point Grid 和View>Snap>  Point Grid Snap  

2. 在功能目錄表選擇 Create Elements  

3. 在 Element Type 選擇欄選擇 ‘General beam/Tapered beam’  

4. 在 Material Name 選擇欄選擇 ‘1 : 鋼材’  

5. 在 Section Name 選擇欄選擇 ‘3 : RH 440x300x11x18’  

6. 在 Beta Angle 選擇欄輸入 ‘0’  

7. 在 Intersect 中選擇 Node 和 Elem （‘’標記） 

8. 指定節點 20(0, 0, 3) 和節點 48(0, 16, 3) 形成○1 列下層的主梁 

9. 指定節點 21(10, 0, 3) 和節點 52(10, 16, 3) 形成○2 列下層的主梁 

10. 指定節點 22(0, 0, 6) 和節點 68(0, 16, 6) 形成○1 列上層的主梁 

11. 指定節點 23(10, 0, 6) 和節點 69(10, 16, 6) 形成○2 列上層的主梁 
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變更中間層小梁斷面及端點釋放 

 

 

圖 10.  轉換中間層小梁斷面及端點釋放 

 

 

1. 將視景切換到上視圖  Top View 

2. 點擊圖示選單   Select Single 後，窗選中間層的小梁(單元111~114、

117~120)將之選取 

3. 主選單 Node/Element>  Change Element Parameters 

4. 在 Parameter Type 選擇欄中選擇 Section ID 

5. 在 Section Name 選擇欄中選擇‘4: RH 350x350x12x19’ 

6. 點擊  鍵 ， 完成斷面尺寸變更  

7. 在樹形選單的 Works 表單中點擊 Section ‘ 4 : RH 350x350x12x19 ’，選取

小梁單元 

8. 利用 Model>Boundaries>Beam End Release…點擊 Pinned-Pinned 將小梁

單元端點釋放改為鉸接 
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建立屋頂主梁 
 

利用 Node/Element>  Create Elements 建立屋頂層的主梁單元。(同圖11的）    

 

 

 圖11.  建立屋頂主梁 

 
 

1. 在功能目錄表選擇 Create Elements (圖11的） 

2. 在 Section Name 選擇欄選擇 ‘5 : H294x200x8x12’  

3. 在 Beta Angle 選擇欄選擇 ‘0’  

4. 指定節點 2(0, 0, 9) 和節點 53(0, 16, 9) 建立屋頂層的主梁(圖11的） 

5. 指定節點 16(10, 0, 11) 和節點 64(10, 16, 11) 建立屋頂層的另一個主梁

（圖11的） 
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建立縱向桁架 

 

利用 Structure Wizard 來建立位於構架○3 列（參見圖1）的縱向桁架。 

 

建模以前先利用主選單的 View>View Point>  Rotate Left 或圖示選單的  

Rotate Dynamic 將模型旋轉成操作方便的角度。縱向桁架的輸入方法與屋頂桁架的

輸入方法基本相同，其步驟如下。 

 

1. 點擊圖示選單  Rotate Dynamic 將模型旋轉成方便操作的視景。 

2. 在主選單選擇 Structure>Structure Wizard>Truss 

3. 在 Input 表單（圖12(a)）的 Type 選擇欄選擇如 所示的桁架形狀 

4. 在 Number of Panels（上下弦分割數）輸入欄輸入 ‘8’  

5. 在 L（桁架長度）輸入欄輸入 ‘8’ m 

6. 在 H1（桁架高）輸入欄選擇 ‘1’ m 

7. 在選擇欄選擇 ‘Sym.’ 對稱 

8. 選擇 Show Dimension 顯示尺度 

   

(a) Input (b) Edit (c) Insert 

  圖12.  桁架建模精靈 
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1. 切換至 Edit 表單  

2. 在 Material 選擇欄選擇 ‘1 : 鋼材’  

3. Top 上弦桿斷面輸入欄輸入 ‘7 : CT 147x200x8x12’  

4. Bottom 下弦桿斷面輸入欄輸入 ‘7 : CT 147x200x8x12’  

5. Diagonal 對角斜撐構件輸入欄輸入 ‘8 : C150x75x6.5x10’  

6. 選擇 ‘Merge Straight Members’ 合併連續的單元  

   

 

1. 切換至Insert 表單  

2. 在 Insert Point 輸入欄輸入 ‘20, 0, 9’ 或利用滑鼠編輯功能指定節點 4 做

自動輸入。 

3. 按 Beam End Release 的 Assign 按鈕取消所有梁端預設鉸接的束制條件 

4. 在 Rotation-Gamma 輸入欄輸入 ‘90’  

5. 在 Origin Point 選擇欄選擇 ‘12(0, 0, 1)’  

6. 點擊  鍵  

7. 選擇側面桁架建立無誤後，點擊 Truss Wizard 對話視窗的  鍵 

8. 點擊圖示選單  Iso View  

 

 

  圖13.  建立縱向桁架 

  Alpha、Beta和Gamma
是在將桁架模型插入到整體
模型中時，對全球座標系
X、Y、Z軸的旋轉角度。 

 選擇Show No.時，節點
編號會顯示在畫面上，以便
於查找原點。 

 單元中間有節點，該節
點又不與其他桿件相連時，
合併該單元。 
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 註解1. 

 

在midas Gen中，如果使用者想知道節點與節點間的距離或單元的長度時，可利用
查詢功能。 

 

選擇 Query> Query Nodes… 或 Query Elements… 選單，畫面上會出現查詢的對
話視窗。在選擇 Node 表單的狀態下，用滑鼠指定模型視窗所輸入的2個節點，在
訊息視窗就會給出各節點的位置資訊和兩點間的距離。 

 

使用相同方法，選擇查詢對話視窗的 Element 表單，用滑鼠指定所選單元，在訊
息視窗中就會顯示相應單元的各種資訊。 
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建立抗風斜撐構件 

 

 

圖14.  建立抗風斜撐構件 

 

1. 在功能目錄表（圖14的）中選擇  Create Elements 

2. 在 Element Type 選擇欄選擇 ‘Truss’ 

3. 在 Material 選擇欄選擇 ‘1 : 鋼材’ 

4. 在 Section 選擇欄選擇 ‘9 : 2L 90x125x10-19 

5. 若在 Intersect 的 Node 和 Elem 若有‘’的標記，再次點擊將其解除 

6. 連接X-Z平面上的節點 5(10, 0, 0) 和節點 4(20, 0, 9) 形成對角斜撐構件 

7. 連接節點 3(20, 0, 0) 和節點 6(10, 0, 9) 形成另一個對角斜撐構件 

8. 使用與步驟6、7同樣的方法建立位於屋頂層斜撐 

9. 使用與步驟6、7同樣的方法建立Y-Z平面上的其他斜撐構件 

 

 

 

   若交叉分割的單元處
於 ‘’狀態，則在輸入X形
對角構件時，單元會自動
在交點處被分割。所以此
時需將 ‘’標記消除。 

 對新構件的節點確認較
為困難時，可將 Hidden
轉為Toggle off，或利用縮
放和旋轉將其變更為便於
確 認 的 視 點 後 再 進 行 輸
入。  
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利用對稱複製功能完成整體模型 

本例題的模型以○C 列（參見圖1）為中心對稱，所以可將所輸入的模型以○C 列為

對稱面進行對稱複製，從而完成整個模型。(此步驟是用以練習Mirror Element功能) 

 

1. 點擊圖示選單  Node Number ,  Shrink Element,  

2. 主選單 View>View Point>  Right View  

3. 在功能目錄表（圖15的）中選擇 Mirror Elements  

4. 在圖示選單中點擊  Select Window 

5. 如圖15的所示，將滑鼠自右向左拉來選擇所要複製的節點和單元 

6. 在 Mode 選擇欄中選擇 ‘Copy’   

7. 選擇 Reflection 鏡射平面為 z-x Plane，指定○C 平面上的任意節點，將自

動輸入 ‘16’ 

8. 勾選‘Copy Node Attributes’以及‘Copy Element Attributes’ 

9. 點擊  鍵  

10. 點擊圖示選單  Iso View  

 

 

圖15.  選擇將被鏡射的單元  

   在選擇複製物
件時需排除位於對
稱面上的單元。利
用（圖15的）或

 Select Window
選擇物件時，若將
滑鼠自左向右拉則
只能選擇完全包含
於領域內的單元。
若將滑鼠自右向左
拉則不完全包含於
區域內的單元也會
被選擇。所以在此
應 選 擇 從 右 向 左
拉。 

  因 視窗選擇
功能處於開啟狀態
時無法使用捕捉功
能，故需在進行步
驟8以前將 視窗
選 擇 轉 為 關 閉 狀
態。 

 



由右而左框選 
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   輸入結構的支承條件 

建立完模型之後，需定義邊界條件。在此將柱子下端的支承條件假定為鉸支承。 

 

圖16.  輸入支承條件 

 

1. 選擇 Boundaries>Supports（圖16的） 

2. 主選單 View>Select>  Select Plane 

3. 選擇 ‘XY Plane’  

4. 在 Z 座標輸入欄輸入柱子下端的Z軸座標 ‘0’ 後，點擊  鍵或

用滑鼠指定柱子下端的任一節點後，點擊  鍵 

5. 在 Options 選擇欄選擇 ‘Add’  

6. 在 Support Type 選擇欄勾選 ‘D-ALL’   

7. 點擊  鍵  

 

  若在相應節點設定過
節點座標系時，自由度束
制方向也可以按節點座標
系為準輸入。 
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    輸入各種載重 
 

設定載重狀況  

 

在輸入載重之前先設定載重狀況。 

 

1. 在如圖16的中選擇 Load 表單  

2. 點擊 Load Case Name 右側的  關聯按鈕  

3. 在 Static Load Cases 對話視窗中輸入如圖17所示的載重狀況  

           

 

圖17.  輸入載重狀況 

 

輸入自重 

 

構件的材料和斷面被定義後，程式將根據其體積和單位重自動計算結構的自重。透

過在 Self Weight 自重指令中輸入係數可以定義其作用方向。 

 輸入方法請參考  “例
題1”的“設定載重條件”或
On-Line Help。 

  在極限設計法中，屋
面上活載與一般層活載的
荷載因子(Load Factor)

不同，故載重狀況也需單
獨輸入。本例主要讓使用
者多練習輸入方式，故將
兩項活載分開設定。 
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輸入自重的步驟如下。 

 

1. 在功能目錄表（圖18的）中選擇 Self Weight 

2. 在 Load Case Name 選擇欄選擇 ‘Self Weight’  

3. 在 Self Weight Factor 的 Z 中輸入 ‘-1’ 

4. 在 Operation 選擇欄點擊  鍵  

 

 

 圖18.  輸入自重 

輸入樓版載重  

 

中間層的樓版載重依以下方式輸入。 

此例題中上下兩個中間樓層的結構形式相同，載重的大小也相同。所以在此採用將

上下層的樓版載重同時輸入的方法。 
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在 Assign Floor Load 指令中輸入載重時，為防止出錯可將加載平面Active啟用之

後再輸入載重範圍。 

 

1. 在功能目錄表（圖19的）中選擇 Assign Floor Load 

2. 點擊 Floor Load Type 右側的  關聯按鈕設定樓版載重類型  

3. 在 Floor Load & Description 的 Name 輸入欄中輸入 ‘Floor’  

4. 在 Description 輸入欄輸入 ‘2-3F’  

5. 在 Load Case 1 中選擇 ‘DL’ 並在 Floor Load 輸入欄輸入 ‘- 0.3’  

6. 在 Load Case 2 中選擇 ‘LL’ 並在 Floor Load 輸入欄輸入 ‘- 0.5’  

7. 點擊  鍵  

8. 點擊  鍵  

9. 在 Load Type 選擇欄選擇 ‘Floor’  

10. 在 Distribution 選擇欄選擇 ‘One Way’ 

11. 為了同時輸入上下層樓版載重， 勾選 Copy Floor Load 

12. 在 Axis 選擇欄選擇 ‘z’  

13. 在 Distances 輸入欄輸入 ‘3’ m  

14. 點擊圖示選單  Front View 

15. 點擊圖示選單的  Select Window，將滑鼠從左向右拉只選擇下部的樓層 

16. 點擊圖示選單  Active  

17. 點擊圖示選單  Node Number (切換 on) 

18. 點擊圖示選單  Iso View  

19. 用滑鼠單擊 Nodes Defining Loading Area 指定載入區域的節點輸入欄後，

依次用滑鼠指定將輸入樓版載重的封閉多邊形的各角上的節點（節點104, 

20, 21, 108, 104) 

20. 點擊圖示選單  Shrink Element (切換 off) 

21. 點擊圖示選單  Active All 

 

 

   在 輸 入 樓 版 載 重
時，若使用者指定載入
區域，則載重角度(A1)
和小梁角度(A2)會由1st
和2nd節點來決定，因此
選擇載入順序時要格外
注意。（請參考On-Line
 Help） 

 若在Convert to Beam
 Load Type欄不表示‘’
的話，所輸入的載重會
按樓版載重形態儲存，
便於以後修改。 

 Sub Beam Weight以
‘’表示的話，在施加樓
層載重時若設置有虛擬
梁(Unmodeled Sub-Beam)

則該虛擬梁的自重會附
加於相應載重狀況的樓
版載重中。 
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輸入 Floor Load Type 

 

 

圖19.  輸入樓版載重  

 在Display Options的Size
表單中Label Symbol選項
可以對樓版載重標示的大
小進行調整。 
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輸入傾斜屋頂載重  

 

將傾斜屋面上所作用的靜載重和活載重輸入於屋頂桁架的上弦構件及屋頂主梁。  

 

在midas Gen中，可以對所有平面模型按 Floor Load 樓版載重功能施加載重。因此，

除了本例中傾斜屋面上所作用的靜載重和活載重外，對於雪載重和風載重也可以利

用樓版載重功能來簡單準確地輸入。  

 

使用 Floor Load 樓版載重功能輸入作用於傾斜屋面上的靜載重和活載重。  

 

1. 點擊圖示選單  Front View  

2. 點擊圖示選單  Hidden (切換 off) 

3. 在功能目錄表（圖20的）中選擇 ‘Assign Floor Load’  

4. 點擊 Load Type 右側的  關聯按鈕，並在 Name 輸入欄輸入 ‘Roof’ 

5. 刪除 Description 輸入欄的內容 

6. 在 Load Case 1 中選擇 ‘DL’ 並在 Floor Load 輸入欄輸入 ‘- 0.11’  

7. 在 Load Case 1 中選擇 ‘LR’ 並在 Floor Load 輸入欄輸入 ‘- 0.1’  

8. 點擊  鍵   

9. 點擊  鍵  

10. 在 Floor Load Type 選擇欄選擇 ‘Roof’  

11. 在 Distribution 選擇欄選擇 ‘One Way’  

12. 點擊圖示  Select Polygon，如圖20的所示只選擇屋頂桁架的上弦 

13. 點擊圖示選單  Active 和  Iso View 

14. 在 Unmodeled 未建模小梁的 No. of Sub-Beam 輸入 ‘3’ 

15. 在 Sub-Beam Angle(A2) 選擇 ‘90’  

16. 在 Unit Self Weight 輸入 ‘0.05’   

17. 點擊 Copy Floor Load 解除 ‘’  

18. 單擊 Nodes Defining Loading Area 輸入欄，並依次點擊節點 2, 16, 121, 

109, 2   

19. 依次點擊節點 16, 4, 117, 121, 16 

 利用  Select Polygon
選擇節點或單元時，需雙
擊所選擇領域的最後一個
點。  

  如同雪載重一樣，載重
的大小由屋頂的垂直投
影面之面積來決定時，
需在 Projection 選擇欄
內選擇 ‘Yes’。  

 利用狀態列的快速查詢
( ) 功 能 （ 如 圖 2 0 的
）可以方便地對節點
或 單 元 的 屬 性 進 行 確
認。  

 在Sub Beam Weight以
‘’表示的話，在施加樓
層載重時若設有虛擬梁  
(Unmodeled Sub-Beam)則
該虛擬梁的自重會附加於
相應載重狀況的樓版載重
中。 
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20. 點擊圖示選單  Active All  

21. 點擊圖示選單的  Node Number (切換 off) 

 

 
 

 

圖20.  傾斜屋頂載重的輸入 
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輸入X方向風力載重 

 

本例中將X方向的風載重按均佈線載重輸入。 
 
在實際設計過程中，風載重應考慮構件的排列和受壓面積等因素，施加在受風的牆
面和屋頂面。但在本例題中為了簡化計算，假設風載重作用在列的柱和梁上，風
載重的大小為 0.88 tonf/m 的均佈線載重。 
 

 

1. 點擊圖示選單  Select by Plane 

2. 選擇 ‘YZ Plane’  

3. 用滑鼠點擊結構○1 列（參見圖1）上任意一點， X 座標輸入欄自動顯示

為 ‘0’ 

4. 點擊  鍵 

5. 過濾選取器選擇 ‘z’ 

6. 點擊 Activate All 圖形按鈕，選取該面上所有的柱桿件，再將過濾選

取器改回 none 

7. 在功能目錄表（圖21的）中選擇 ‘Element Beam Loads’ 

8. 在 Load Case Name 選擇欄選擇 ‘WX’  

9. 在 Options 操作選擇欄選擇 ‘Add’  

10. 在 Load Type 選擇欄選擇 ‘Uniform Loads’ 

11. 在 Direction 選擇欄選擇 ‘Global X’  

12. 在 Projection 投影選擇欄選擇 ‘No’  

13. Value 項目選擇 Relative，x1 輸入 0、x2 輸入 1 

14. 在 w 輸入欄輸入 ‘0.88’  

15. 點擊  鍵  
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圖21.  輸入X方向的均佈線載重 
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單元詳細表格 

 

點擊功能目錄表右側的  鍵（圖22 ），可以使用表格確認輸入的梁單元載重。 

 

查看任意單元上輸入的載重內容時，使用 Element Detail Table 會很方便。 
 

 

圖22.  單元詳細表格 

 

1. 點擊圖示選單  Select Previous 

2. 在主選單選擇 Query>Element Detail Table  

3. 在圖22的 可以對 Bmld 資料表格內所選擇的單元的載重輸入狀態進

行編輯 

4. 在圖22的點擊關閉鍵（ ） 關閉表格 

5. 點擊圖示選單  Unselect All 全部解除選取 
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輸入Y方向風力載重 

 

將Y方向的風力載重假設為節點集中載重。 
 

 

圖23.  輸入Y方向風載重 

 

 

1. 主選單 View>Select>  Plane 

2. 選擇 ‘XZ Plane’  

3. 點擊一下 Y Position 座標輸入欄，指定結構○A 平面上的任意節點 

4. 點擊  鍵  

5. 在功能目錄表（圖23的）中選擇 Nodal Loads  

6. 在 Load Case Name 選擇欄選擇 ‘WY’  

7. 在 Options 操作選擇欄選擇 ‘Add’  

8. 在 FY 輸入欄輸入 ‘0.92’  

9. 點擊  鍵，在圖23的點擊  鍵 
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選擇節點載重的輸入內容。 

 

1. 點擊圖示選單  Select Previous 

2. 在主選單選擇 Query>Node Detail Table  

3. 在圖24的可以對 Cnld 資料表格內所輸入的節點載重進行編輯 

4. 在圖24的 點擊關閉鍵（ ） 關閉表格 

5. 點擊圖示選單  Unselect All 

 

 

圖24.  節點詳細表格 
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利用樹形選單查看模型輸入資料  

 

在midas Gen中提供了新的建模概念－Works Tree 樹形選單。在樹形選單中，可以

對建模過程中輸入的各種資料進行系統的管理，並提供拖放方式的建模方法。 

 

1. 在圖25的選擇 Works 表單 

2. 在 Boundaries>Supports 選擇 ‘Type 1[111000]’ 後點擊滑鼠右鍵，選擇 

‘Display’ 即可顯示支承 

3. 在圖26中查看模型中所輸入的支承條件 

4. 選擇 Static Load>Static Load Case 2[DL ;Dead Load] 的 ‘Floor Load:4’  

5. 按滑鼠右鍵，在 關聯選單 選擇 ‘Display’ 顯示載重 

6. 在圖27中查看所輸入的樓版靜載重  

7. 點擊  Display，在 Boundary 表單中解除 Support 的‘’記號 

8.  點擊  鍵  

  

 

 
 

   圖25.  在樹形選單選擇Works表單 
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              圖26.  在樹形選單中查看支承條件 

 

 
圖27.  在樹形選單中查看所輸入的樓版載重 
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  執行結構分析 

 

點擊圖示選單   Analysis 執行分析，或在主選單中執行Analysis> Perform 

Analysis。分析結束後程式的環境會自動轉換成可查看分析結果以及可進行設計工

作的後處理模式。 

 

如果需要修改所輸入的資料時，需重新回到前處理模式，此時可以點擊圖示選單 

 Preprocessing Mode，或在主選單中選擇 Mode>Preprocessing Mode。  

 

 

 

 

 

 

  查看分析結果 
 

載重組合條件 

 

在查看分析結果前先利用主選單的 Results> Load Combinations 功能來建立載重

組合。 

 

本例題利用 Auto Generation 自動產生功能快速建立了AISC-Limit State Design 

Method 設計法所採用的載重組合，若加入 Service Load 服務載重 組合則可用於

檢核變位與反力。 
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1. 在主選單選擇 Results> Load Combinations  

2. 選擇 Steel Design 表單 

3. 點擊  鍵  

4. 在 Option 選擇欄選擇 ‘Add’  

5. 在 Design Code 選擇欄選擇 ‘AISC(14th)-LRFD10’  

6. 點擊  鍵 

7. 在  Load Combination List 的  Name 選擇欄點選  ‘sLCB31’ 查看右方 

Load Cases and Factors 欄位內載重與對應的係數資訊 

8. 新增一組 ‘sLCB32’ 的載重狀況，輸入資訊如圖28 所示  

9. 點擊 Load Combinations 對話視窗的  鍵  

 
 
 

圖28  載重組合對話視窗 

 在自動產生載重組合條件

時，載重狀況會直接依使用

者所賦予的載重狀況名稱反

映在Description中，如風載重

和地震載重等。  
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查看反力 

 

1. 在主選單選擇 Results>Reactions>Reaction Forces/Moments…  

2. 在 Load Case/Combinations 選擇欄選擇 ‘CBS:sLCB1’  

3. 在 Components 選擇欄選擇 ‘FZ’  

4. 在 Type of Display 選擇欄‘’勾選 ‘Value’ 和 ‘Legend’   

5. 點擊  鍵  

 

 

圖29. 載重組合1的反力 
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位移等值線圖 

 

 

圖30.  變形等值線圖 

 

1. 點擊圖示選單  Hidden Surface 

2. 選擇 Deformations 表單（圖30的） 

3. 在功能目錄表中選擇 Displacement Contour  

4. 在 Load Cases/Combinations 選擇欄中選擇 ‘CBS:sLCB4’  

5. 在 Components 選擇欄選擇 ‘DXYZ’  

6. 在 Type of Display 選擇欄選擇 ‘Deform’、‘Legend’ 表示‘’ 

7. 解除對 ‘Values’ 的選擇 

8. 點擊 Contour 右側的   

9. 在 Number of Colors 選擇欄選擇 ‘18’  

10. 在 Contour Options 選擇欄對 Gradient Fill 顏色梯度擴散表示‘’ 

11. 點擊 Apply Upon OK 刪除 ‘’ 標記 

12. 點擊  鍵  

13. 點擊 Deform 右側的   

14. 在 Deformation Type 選擇欄選擇 ‘Real Deform’ 並點擊  鍵  

15. 在狀態列的單位變換窗選擇 ‘mm’ 並點擊  鍵 

16. 點擊圖示選單  Perspective 透視視景 

17. 主選單 View>  Render View  3D動態彩現視窗 
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在後處理階段，若適當的使用  Render View 和  Perspective 功能可以得到

多種形式的輸出畫面。 
 

 

圖31.  變形圖的透視視景 

 

 

圖32. 在結構內部查看變形 
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彎矩圖 

 

1. 主選單 View>  Render View  

2. 選擇 Forces 表單（圖33的）  

3. 在功能目錄表中選擇 Beam Diagrams 

4. 在 Components 選擇欄選擇 ‘Myz’  

5. 在 Display Options 選擇欄選擇 ‘Exact’、‘Line Fill’  

6. 在 Type of Display 中選擇 ‘Contour’、‘Value’ 、‘Legend’ 

7. 解除對 ‘Deform’ 的選擇 

8. 點擊 Value 右側的  鍵  

9. 在 Decimal Points 小數點以下位數輸入 ‘1’ 後，點擊  鍵  

10. 在單位變換窗選擇 ‘m’，並點擊  鍵  

 

 

圖33. 整體模型的彎矩圖 
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如圖33，若單元非常多時很難在彎矩圖上清楚地查看構件內力。此時可以利用 

 Select Plane 功能選擇所要查看的平面並將該平面Active啟用顯示。 

 

1. 主選單 View>Select >  Select Plane  

2. 選擇 ‘XZ Plane’  

3. 用滑鼠點擊 Y 座標輸入欄並點擊○A 平面上的任意一點，將自動輸入 ‘0’ 

4. 點擊 Select Plane and Volume 對話視窗中的  鍵 

5. 點擊圖示選單  Active  

6. 點擊圖示選單  Front View  

  

 

圖34. 立面構架 ○1 （參見圖1）的彎矩圖 
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查看構件應力及動畫製作 

 

1. 點擊圖示選單  Iso View ,  Perspective ,  Active All  

2. 選擇 Stresses 表單（圖35的）  

3. 在功能目錄表中選擇 Beam Stresses  

4. 在 Load Cases/Combinations 選擇欄選擇 ‘CBS:sLCB8’  

5. 在 Components 選擇欄選擇 ‘Combined’ 組合應力 

6. 在 Type of Display 中選擇 ‘Deform’、‘Legend’ 

7. 解除對 ‘Value’ 的選擇 

8. 在單位變換窗選擇 ‘cm’ 

9. 點擊  鍵  

 

 

圖35  梁的組合應力圖  

1. 如圖36所示，在 Type of Display 中選擇 Animate，並將 ‘Legend’ 的 ‘’

選項解除 

2. 點擊  鍵 

3. 如圖36所示，點擊  Record 
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圖36  動畫畫面  

 

與“例題1”所說明的一樣，在查看分析結果時，既可以利用圖形來查看結果，也可

以利用 Text Output… 透過輸出文件來查看分析結果。 

 

透過執行主選單的 Results>Text Output… 指令，使用者可以定義要輸出的載重集

合、輸出內容（反力、變形、構件內力、應力等）、輸出物件（單元種類、單元編

號、斷面編號、材料編號、樓層等），以及輸出形式（最大/最小值等）。 

 

在midas Gen的 Test Editor 中可以匯入和列印輸出檔（fn.ANL），還可以依結構計

算書的形式添加頁首和頁尾，便於使用者製作計算書。 

 

關於報表輸出功能的詳細內容請參考On-Line Help。 

 

  

例題 2 END 






