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概要 

 

本例題介紹使用 midas Civil 的非線性動力歷時分析功能來進行含有

LRB隔震單元的建模分析方法。  

 

 
 

例題使用的是簡化的鋼箱型橋梁模型，橋梁結構係由主梁、橫梁和橋

墩構成。橋臺部分由於勁度很大，不另外建立模型而僅輸入邊界條件來模

擬；基礎部分假設完全固定，也只依邊界條件來定義。  

 

以下是鋼橋梁的一些基本資料。 

 

跨    徑：45 m + 50 m + 45 m = 140 m 

橋    寬：11.4 m 

主梁形式：鋼構箱型梁 

鋼    材：CNS(S) SM490（主梁） 

混 凝 土：CNS(RC) C280（橋墩） 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖1. 橋梁剖面圖 

 [單位：mm] 

主樑 Girder 

Box 2000x2500x12x16/18 
橫樑 Cross Beam 

I 1500x300x12x12/12 
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設定操作環境及定義材料和斷面  

 

開啟新檔（  New Project），以„Response.mcb‟為檔名儲存(  Save)。 

 

File   New Project…  

File / Save ( Response ) 

 

 

將單位系統設定為 Tonf, m。 

 

Tools / Unit System… 

Length > m  ;  Force (Mass) > Tonf   

 

 

定義材料 
 

分別輸入主梁和橋墩的材料資料。 

 

主選單 Properties>Material Properties    

Material ID ( 1 )   ;   Type of Design > Steel   

Standard > CNS06(S)  ;   DB > SM490   

Material ID ( 2 )   ;   Type of Design > Concrete   

Standard > CNS560(RC)  ;  DB > C280   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖2. 定義材料 
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定義斷面 

 

使用 User 自行輸入主梁、橫梁以及橋墩的斷面資料。 

 

主      梁：  箱型梁 2000×2500×12×16/18 

橫      梁：  I 型鋼 1500×300×12×12/12 

柱      帽：  長方形斷面 1500×1500 

橋      墩：  圓形斷面   1500 

 

主選單 Properties>  Section Properties    

DB/User 表單 

Section ID ( 1 ) ; Name ( Girder ) ; 斷面形狀 > Box  ; User  (開) 

輸入：H ( 2 )  ;  B ( 2.5 )  ;  tw ( 0.012 )  

 tf1 ( 0.016 )  ;  C ( 2.3 )  ;  tf2 ( 0.018 )   
 

Section ID( 2 ) ;Name ( Cross ) ; 斷面形狀 > I-Section ; User  (開)

輸入：H ( 1.5 ) ; B ( 0.3 ) ; tw ( 0.012 ) ; tf1 ( 0.012 )   
 

Section ID ( 3 ) ; Name ( Coping ) ; 斷面形狀 > Solid Rectangle  ;

 User  (開) ,  輸入: H ( 1.5 )  ;  B ( 1.5 )   
 

Section ID ( 4 ) ; Name ( Column )  ;  斷面形狀 > Solid Round ;

 User  (開)  , 輸入:  D ( 1.5 )   
 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖3. 定義斷面 

 輸入斷面尺寸

時，若只輸入tf1，
不輸入tf2，則 tf2

與 tf1相同。 
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建立結構模型 

 

主梁及橫梁模型 

 

使用  Create Nodes 建立節點後，透過  Extrude Element 功

能將節點依 28@5m 擴展成梁單元來建立主梁。  

 

 Top ;   Auto fitting (開) 

主選單 Node/Element>Nodes>  Create Nodes…  

Coordinates ( 0, 0, 0 )   

Copy > Number of Times (1)   

Distances (dx, dy, dz) > (0, 7.7, 0)   
 

主選單 Node/Element>Elements>  Extrude… 

 Select All 

Extrude Type > NodeLine Element 

Element Attributes > Element Type > Beam 

Material > 1: SM490 ;  Section > 1: Girder   

Generation Type > Translate  

Translation > Equal Distance  

dx, dy, dz ( 5, 0, 0 )  ;  Number of Times ( 28 )   

  
 
 

 

圖4. 輸入主梁 
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輸入橫梁 

 

在主梁起點處使用  Create Elements 功能連接兩個節點建立一

個橫梁後，可透過將該梁依橋梁縱向複製來建立其餘的橫梁。 

 

 Node Number (開) 
 

主選單 Node/Element>Elements>  Create Elements… 

Element Type > General beam/Tapered beam 

Material > 1:SM490  ;  Section > 2:Cross  ; 

Beta Angle ( 0 ) 

Nodal Connectivity ( 1, 2 )  
 

 

主選單 Node/Element>Elements>  Translate…  

 Select Recent Entities 選取前次建立的物件單元 

Mode > Copy  ;  Translation > Equal distance  

dx, dy, dz ( 5, 0, 0 ) ;  Number of Times ( 28 ) 

 

 

 

圖5. 輸入橫梁 

 

輸入橋墩 

 

如圖6所示，在橋墩的位置建立模型後，透過剛性連接(Rigid Link)來

模擬實際結構。橋墩的剖面如圖7所示。 
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圖6. 橋墩和上部結構連接示意圖 

 

 

 

圖7. 橋墩模型 

剛性連接 

剛性連接 

LRB 

剛性連接 

1.25 

0.20 

0.75 

0.75 

[單位 : m] 
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剛性連接 

 

選擇主梁支承處的節點，將其往 z 軸方向複製，產生要進行剛性連

接的節點。(參考圖6) 

 

 

    Element Number (開) ;  Node Number (關) 
 

 Select by Window (單元 : 選擇如圖8的單元19~38)   

 Activate  

Element Number (關) 

 Iso View  ;  Node Number (開) 
 

主選單 Node/Element>Nodes>  Translate… 

 Select Single (節點 : 19, 20, 39, 40 ) 

Mode > Copy  ;  Translation > Unequal distance  

Axis > z  ;  Distance ( -1.25, -0.2, -0.75 )    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

圖8. 複製節點 
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在要建立橋墩和橫梁的位置產生節點。  

 

 

主選單 Node/Element>Nodes>  Divide … 建立橋墩柱的位置節點 

Divide > Equal Distance (開) ;  Number of Divisions (2) 

Nodes to Divide (67, 68)
  ;   (69, 70)

  
 自動建立節點 71, 72 

 

主選單 Node/Element>Nodes>  Translate…產生柱帽節點 

 Select Single  (節點 : 71, 72 ) 

Mode > Copy  ;  Translation > Unequal distance  

Axis > y  ;  Distance ( 11.7/2, -11.7 )   

 建立節點 73, 74, 75, 76 
 

 Select Previous 

Axis > z  ; Distance (-0.75, 7@-1 )   

 建立墩柱節點 77~92 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

圖9. 輸入橋墩的節點 
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建立橋墩和橫梁 

 

使用  Create Elements 功能建立橋墩和橫梁。(參考圖7) 

 

主選單 Node/Element>Elements>  Create Elements…  

Element Type > General beam/Tapered beam 

Material > 2:C280  ;  Section > 3:Coping 

Beta Angle ( 0 )  ;  Intersect > Node (開) (圖10的) 

Nodal Connectivity ( 73, 75 )


   建立第一個橫梁 

Nodal Connectivity ( 74, 76 )


   建立第二個橫梁 
 

Material > 2:C280  ;  Section > 4:Column  

Beta Angle ( 0 )  ;  Intersect > Node (開)  

Nodal Connectivity ( 77, 91 )


   建立第一個墩柱 

Nodal Connectivity ( 78, 92 )


   建立第一個墩柱 

 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖10. 建立橫梁和橋墩 

 

① 
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輸入邊界條件 

剛性連接 

 

將在實際位置建立的主梁和支承、支承和橋墩分別使用 剛性連接 連

接起來。（參考圖6）  
 

 

 Fit,   Zoom Window (放大第一個橋墩的橫梁部分) 
 

主選單 Boundary> Rigid Link…  

 Select Single ( 節點 : 60 ) 

Master Node Number ( 20 )


 

Typical Types > Rigid Body 

Copy Rigid Link (開) ; Axis > x  ;  Distance ( 50 ) 
 

 
 

 Select Single (節點 : 59 ) 

Master Node Number ( 19 )


   
 

 Select Single (節點: 68 ) 

Master Node Number ( 64 )


   
 

 Select Single (節點: 67 ) 

Master Node Number ( 63 )


   
 

 Select Single (節點: 77 ) 

Master Node Number ( 71 )


   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖11. 主梁和支承及橋墩間的剛性連接 

 已輸入的剛性連
接可進行複製。 
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輸入橫梁的梁端剛域 

 

由於建模時所有的構件單元是以中心軸為基準相互連接的，故會有如

圖13所示的主梁和橫梁間由於主梁的梁寬導致的重複部分出現。對此可使

用 Beam End Offset 功能透過輸入剛域長度使程式在計算勁度時將該部

分的影響排除。  

輸入梁端剛域長度的方法有整體座標系(Global)和單元座標系(Element)

兩種類型。若選擇整體座標系類型，則對於所輸入的剛域長度不考慮載重，

只針對扣除剛域後的單元長度計算勁度和自重。  

若選擇單元座標系的話，只在計算勁度時排除輸入的剛域長度，而在

計算自重和施加載重時則將該部分包含在內。（參考 On-Line Help） 

在此使用單元座標系來輸入剛域長度。此時由於需在梁單元的 i、j

端輸入軸向的剛域長度，故需事先確認梁單元的單元座標系方向。  

 

 
 

 Activate All   Left View ;    Hidden (開)   

 

主選單 Boundary>Beam End Offsets…  

 Select by Window (單元 : 橫梁)   

Options > Add/Replace ; Beam Offset > Type > Element 

RGDi ( 1.15 )  ;  RGDj ( 1.15 ) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖12. 輸入橫梁的剛域長度 

 

 

 

i 端  j 端  

① ① 

選取 
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輸入橋臺的支承節點 

 

主梁與橋臺連接的支承部分將於後續使用非線性連接(Nonlinear Link)

來模擬。使用  Zoom Window 放大左右兩側橋臺的連接部分，建立節

點。  

 
 

Zoom Window (放大左右兩側橋臺的橫梁部分) 

主選單 Node/Element > Nodes >  Translate… 

 Select Single (節點 : 1, 2, 57, 58 ) 

Mode > Copy  ;  Translation > Unequal distance  

Axis > z  ;  Distance ( -1.25, -0.2 )    

 

 

輸入橋臺與柱底的邊界條件 

 

橋臺與柱底假設其完全固定，故束制各方向的自由度。 

 

 Hidden (關) ;  Iso View  

主選單 Boundary>Supports> Define Supports…  
 

 Select Single (節點 : 91, 92, 95, 96, 99, 100) 

Options > Add  ;  Support Type > D-All (開), R-All (開)  

 Node Number (關) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖13. 輸入邊界條件 

 使用Query>Query

 Nodes 功能(圖13的
)可在資訊視窗查

詢相應節點的各種輸
入情況，並可非常容
易地查看兩個節點間

的距離。  

① 
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定義非線性連接單元 

Nonlinear Link (LRB) 非線性連接特性值 

Abutment 橋台 (LRB-A) 

 

 

 

 

 

 

 

 

 

 

 

 

Pier 墩柱(LRB-P) 

 

 

 

 

 

 

 

 

 

 

 

 

  

 Vertical  

(垂直向) 

Longitudinal  

(縱向) 

Transverse  

(橫向) 

Direction Dz Dx Dy 

Nonlinear No Yes Yes 

Linear Properties 

Effective Stiffness 479100(design) 336.1(iteration) 336.1(iteration) 

Effective Damping 0 0 0 

Nonlinear Properties 

Stiffness - 1099 1099 

Yield Strength - 15.69 15.69 

Post yield Stiffness ratio - 0.08917 0.08917 

 Vertical 

(垂直向) 

Longitudinal 

(縱向) 

Transverse 

(橫向) 

Direction Dz Dx Dy 

Nonlinear No Yes Yes 

Linear Properties 

Effective Stiffness 1289000(design) 702.2(iteration) 702.2(iteration) 

Effective Damping 0 0 0 

Nonlinear Properties 

Stiffness - 2204 2204 

Yield Strength - 33.63 33.63 

Post yield Stiffness ratio - 0.0862 0.0862 
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輸入非線性連接 (LRB) 特性值 

 

輸入鉛心橡膠隔震支承元件 (Lead Rubber Bearing isolators) 的特性值： 

 

Boundary >  General Link >  General Link Properties 

Define General Link Properties >  

Name (LRB-A) ; Application type > Force;  

Property Type > Lead Rubber Bearing Isolator 

Self Weight > Total Weight : (0) 

Linear Properties 

DOF > Dx, Dy, Dz  (on)  ;  Effective Stiffness (479100), (336.1), (336.1) 

 

Nonlinear Properties 

DOF > Dy  (on)  ;    

Stiffness (k) : (1099) 

Yield Strength :  (15.69) 

Post Yield Stiffness Ratio(r) :  (0.08917) 

Hysteretic Loop Parameter (α) :  (0.5) 

Hysteretic Loop Parameter (β) : (0.5)   

 

DOF > Dz  (on)  ;    (同 Dy 步驟輸入數值 ) 

 

 

圖14. 輸入橋台的LRB-A 特性值  
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輸入墩柱的LRB元件特性值： 

  

Boundary >  General Link >  General Link Properties 

Define General Link Properties >  

Name (LRB-P) ; Application type > Force;  

Property Type > Lead Rubber Bearing Isolator 

Self Weight > Total Weight : (0) 

Linear Properties 

DOF > Dx, Dy, Dz  (on)  ;  Effective Stiffness (1289000), (702.2), (702.2) 

 

Nonlinear Properties 

DOF > Dy  (on)  ;    

Stiffness (k) : (2204) 

Yield Strength :  (33.63) 

Post Yield Stiffness Ratio(r) :  (0.0862) 

Hysteretic Loop Parameter (α) :  (0.5) 

Hysteretic Loop Parameter (β) : (0.5)   

 

DOF > Dz  (on)  ;    (同 Dy 步驟輸入數值 ) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖15. 輸入墩柱的LRB-P 特性值 
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建立非線性連接 (LRB) 

建立支承處的非線性連接 Nonlinear Link (LRB) 單元。 

本例題共有8處要設置LRB元件，以下按順序建立左側橋台、左側墩柱、右側

墩柱、右側橋台的非線性連接單元。 

 

建立左側橋台的非線性連接單元： 

 

Boundary / General Link  

General Link Property > LRB-A 

 Zoom Window ( 放大視窗以便建立左側橋台LRB-A的非線性連接) 

2 Nodes (93, 95)
 

 

2 Nodes (94, 96)
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖16. 建立左側橋台LRB非線性連接 

 

 

建立左側墩柱的非線性連接單元： 

 

Boundary / General Link  

General Link Property>LRB-P 

 Zoom Window (放大視窗以便建立左側墩柱LRB-P的非線性連接) 

2 Nodes (59, 63)
 

 

2 Nodes (60, 64)
 

 

 

 



 

 

 鋼箱型橋樑隔震非線性動力歷時分析  

 

 

17 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖17. 建立左側墩柱LRB非線性連接 

 

建立右側墩柱的非線性連接單元： 

 

 Boundary / General Link  

General Link Property > LRB-P 

 Zoom Window (放大視窗以便建立右側墩柱LRB-P的非線性連接) 

2 Nodes (61, 65)
 

 

2 Nodes (62, 66)
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖18. 建立右側墩柱LRB非線性連接 
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建立右側橋台的非線性連接單元： 

 

 

Boundary / General Link  

         General Link Property > LRB-A 

 Zoom Window (放大視窗以便建立右側橋台LRB-A的非線性連接) 

2 Nodes (97, 99)
 

 

2 Nodes (98, 100)
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖19. 建立右側橋台LRB非線性連接 

 

 

  



 

 

 鋼箱型橋樑隔震非線性動力歷時分析  

 

 

19 

輸入靜載重 

首先定義靜載重的載重狀況。 

 

Load / Static Load Cases… 

Name ( DL ) ;  Type > Dead Load (D)    

 

 

 

 

 

 

 

 

 
 

圖20. 輸入靜力載重狀況 

 

假設靜載重為 1 tonf/m大小均佈載重，用Element Beam Loads輸入。 

 

 Left View 

Load>Beam Load>Element … 

 Select Window (單元:主梁，圖17的) 

Load Case Name > DL  ;  Options > Add   

Load Type > Uniform Loads 

Direction > Global Z ; Projection > No 

Value > Relative  ;  x1 ( 0 )  ;  x2 ( 1 )  ;  w ( -1)   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖17. 輸入主梁靜載重 

① ① 
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輸入質量 

程式中可定義 Structure Mass、Nodal Mass、Load to Mass 等三種類型的質

量數據資訊，各類型質量數據的輸入與應用可參閱on-line線上說明手冊。 

 

當執行模型中具有非線性連接單元（Nonlinear Link）的動力歷時分析時，應

將質量分配給非線性連接單元連接的所有節點。本示範例中，將設定指派 “St

ructure Mass” 及 “Load to Mass” 兩種類型的質量數據。 

 

結構質量 Structure Mass 

 

將模型中結構單元的自重轉換為質量。  

 

Structure  / Structure Type  

 Conversion of Structure Self weight into Masses 

    >  Convert to X, Y, Z   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 圖18. 將結構自重自動轉換為質量 

 

 

  



 

 

 鋼箱型橋樑隔震非線性動力歷時分析  

 

 

21 

 

外力轉換質量 Load to Mass 

 

將先前輸入的外力（梁單元載重）轉換為質量。  

 

Load / Static Loads Load Type /  Loads to Masses  

Mass Direction > X, Y, Z   

Load Type for Converting > Beam Load (Line, Typical)  (on) 

Gravity (9.806) ; Load Case > Dead load   

Scale Factor (1) ; Add   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖19. 將梁單元載重轉換為質量 
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輸入歷時分析資料 

歷時分析函數  

 

本示範例將考慮對靜載重及地震載重的分析。不同於線性分析，疊加原理並不

適用於非線性分析結果中。因此若在分析後以線性組合疊加每次加載的獨立結

果是不正確的。對於歷時分析，我們需要考慮兩種載重同時作用下的受力結果。 

 

為了反應歷時分析中的靜載重，我們將採用 Time Varying Static Load  時變靜

荷載功能。該功能基本上創建了在執行地震荷載的歷時分析時，靜載重到位作

用的條件。我們將建立兩種歷時分析函數，其中 „Ramp‟ 函數指派給靜載重，

而El Centro函數數據用於地震荷載。 

 

首先定義一個斜坡時間函數來表示靜載重作用。 

 

Load / Seismic Load Type / Time History Analysis Data /     Time History Functions  

Add Time Function 

Function Name (Ramp) 

Enter the data as shown in 圖 10. 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖20. 定義靜載重作用的斜坡時間函數 
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地震荷載資料採用 El Centro 歷時函數數據。 

 

Load / Seismic Load Type / Time History Analysis Data /     Time History Functions  

Add Time Function 

Earthquake 

Earthquake>1940 EL Centro Site, 270 Deg  > OK > Apply 

Earthquake 

Earthquake>1940 EL Centro Site, 180 Deg  > OK > OK 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

(a) El Centro Site 270Deg (Peak: 0.3569g) 

 

 

 

 

 

 

 

 

 

 

 

 

(b) El Centro Site 180Deg (Peak: 0.2142g) 

 

圖21. El Centro 地震函數的輸入 
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輸入特徵值分析資料 

 

一般而言，進行歷時分析的方法有模態疊加法（Modal Superposition Method） 

與直接積分法（Direct Integration Method）兩種。本示範例中，我們將採用模

態疊加法進行分析，故在設定歷時分析載重前需先定義特徵值分析控制項。 

 

對於特徵值分析，MIDAS/Civil 提供了Eigen Vectors與Ritz Vectors  Method兩

種解析方法。通常分析模型中使用非線性連接（Nonlinear Link）時，執行非

線性模態歷時分析比較建議使用Ritz Vectors方法。在此情況下，為了將非線

性連接的變形包含於初始荷載向量的計算，非線性連接的力向量必須包含在初

始載重向量中。 

本例我們將採用Ritz Vectors方法分析並勾選 “Include GL-link Force Vector” 項

目。 

 

Load / Seismic / Time History Analysis Data /      Load Cases  

 

(或 Analysis > Eigenvalue Analysis Control) 

         Ritz Vectors 

Starting Load Vectors 

Load Case > Dead load ; Number of Generations > 1   

Load Case > Ground Acc X ; Number of Generations > 8   

Load Case > Ground Acc Y ; Number of Generations > 8    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖22. Eigenvalue Analysis Control 輸入資訊 
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設定歷時分析載重狀況 

 

輸入靜荷載與地震荷載的歷時分析載重狀況。  

 

定義“Dead Load”歷時分析載重。 

 

Load / Seismic / Time History Analysis Data /     Load Cases 

       ADD  

Load Case Name (Dead Load) 

End Time (5) ; Time Increment (0.002)  

Step Number Increment for Output (5) 

Analysis Type > Nonlinear ; Analysis Method > Modal 

Damping > Direct Specification of Modal Damping  

Damping Ration for All Modes > Damping Ratio for All Modes (0.99)


  

 
 

 

各項目的詳細內容說明請參閱On-line Help。  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

圖23. Time History Load Case 輸入資訊 


  99% 阻尼比假設從開始（零秒）到

結束時間的阻尼為 99%。此設定是為
了在使用時變靜荷載的非線性分析中讓
靜載重快速達到收斂。  

End Time：歷時分析的結束時間。 

工程師應考慮地震歷時數據的持續時間

來定義此處的End Time。 

 

Time Increment：時間增量。 

歷時分析的時間增量顯著影響分析結果

的準確性。確定時間增量的常用經驗法

則是使用時間強制函數週期中較小者的

1/10或結構的固有頻率。本例由於所輸

入各筆數據資料的最高周期為0.02，因

此這裡使用0.002。 

 

Step Number Increment for Output：

產生歷時分析結果所需的分析時間步

長。以（輸出步數x時間增量）的間隔

產生的結果。如果指定  1，則每0.002

秒產生分析結果。如果指定  5，則每

0.01秒產生分析結果。此處考量合理的

分析速度，使用5。 

 



 

 

midas Civil 基礎培訓教材 

 

 

26 

 

定義“Earthquake”地震荷載歷時分析載重。 

 

Load / Time History Analysis Data /     Load Cases  

       Add 

Load Case Name (Earthquake) 

End Time (50) ; Time Increment (0.002)  

Step Number Increment for Output (5) 

Analysis Type > Nonlinear ; Analysis Method > Modal


 

Order in sequential Loading > Subsequent to > Load Case > Dead Load 

Damping > Damping Method > Modal 

Damping Ratio for All Modes (0.05)   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  
圖24. Time History Load Case 輸入資訊 

Order in Sequential Loading： 

持續加載的順序。定義與連續加載的多

個時間歷時分析條件順序相關的數據。 

Subsequent to： 

選擇先前定義的歷時分析條件，該條件
在當前定義的歷時分析條件之前執行。
當前的歷時分析條件中的Analysis Type

分析類型與Analysis Method分析方法必
須與前一個荷載條件的分析類型、方法
一致。根據前面的分析條件，得到位
移、速度、加速度、構件力、非線性鉸
發展狀態和非線性連接的變化。 

 

在加載的情況下，當勾選“Keep Final 

Step Loads Constant”項目時，在前一分
析條件的最終階段下的加載將持續保持
在當前的分析條件中。 


 本例亦可採用非線性直接積分方法

（Nonlinear Direct Integration Metho

d）進行分析。採用直接積分法可不需
要進行RitzVector分析，但根據時間增
量的設定情況需要較多的分析時間。  
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輸入地表加速度  

 

接下來指定 El Centro 地表加速度的方向。 

先前輸入兩個時間歷時地震數據函數 Elcent_t 和 Elcent_h 的最大加速度分別

為 0.2142g 和 0.3569g。在第一振動模態的方向上輸入與兩個最大加速度中的

較大者相關的地震數據。也就是說，該模型的第一振動模態是在Y方向上，為

該橋梁的橫向方向。 因此，在Y方向上施加更大的加速度數據（Elcent_h）。 

 

Load / Seismics / Time History Analysis Data /      Ground Acceleration   

Time History Load Case Name > Earthquake 

Function for Direction-X 

Function Name > Elcent_t 

Function for Direction-Y 

Function Name > Elcent_h 

Operations >    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖25. 定義各方向地震資料 
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設定時變靜荷載 

 

採用 Time Varying Static Load 時變靜荷載功能，設定在歷時分析中考慮靜

載重的作用。 

 

Load / Seismic / Time History Analysis Data /     Time Varying Static Load   

Time History Load Case Name > Dead Load 

Static Load > Dead Load 

Function > Function Name > Ramp 

Operations >    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖 26. 輸入時變靜荷載 

 

執行分析 

  

完成邊界非線性分析的各項輸入後，即可執行分析。 

 

Analysis /  Perform Analysis  
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查看分析結果 

歷時分析結果圖形 

 

使用 Time History Graph 歷時分析結果圖形功能查看作用於LRB隔震器上的

剪力和橋墩頂部的變位情況。 

 

 

Initial View 

View /  Display 或 Display from the Icon Menu 

Boundary 表單 

General Link (on)  ; General Link Number (on)   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖 27. 初始模型視景與顯示 Nonlinear Link 編號  
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查看非線性連接 General Link No.3 的縱向水平力和變形情況。 

 

 

Result / Time History Result /  T.H Graph/Text /   Time History Graph 

Define/Modify Function > General Link Deform/Force 

 

Name (NL3-Shear-y) 

NL-Link No > 3(nl:59,n2:63)   ;  Type > J-Node Force 

Components > F-y  ;  Time History Load Case > Earthquake   

 

Name (NL3-Disp-y) 

NL-Link No > 3(nl:59,n2:63)  ;  Type>Deformation 

Components > D-y  ;  Time History Load Case > Earthquake   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖 28.  General link No.3 縱向水平力和變形 
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輸出LRB隔震器的磁滯圖形。 

 

 

Result / Time History Result /  T.H Graph/Text /  Time History Graph 

Check Function to Plot > NL3-Shear-y (on) 

Click Add from list 

Horizontal Axis > NL3-Disp-y 

Type of Display 

X Axis Decimal Pt. (4)  ; Y Axis Decimal Pt. (1) 

Type > Time History Graph   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖 29. LRB隔震器的磁滯圖形 
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使用時間歷時圖形查看橋墩頂部的變位情況。 

 

 

Result / Time History Result /  T.H Graph/Text /  Time History Graph 

Define/Modify Function > Disp/Vel/Accel 

 

Name: (Disp-Pier-Top) 

Node Number: (77) 

Type of Result > Displ. 

Components  > DX 

Time History Load Case > Earthquake  

Included Mode Number > All   

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖 30. 設定顯示橋墩頂部變形的各項參數 
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查看時間歷時圖形確認橋墩頂部的變位。 

 

 

Result / Time History Result /  T.H Graph/Text /  Time History Graph 

Check Function to Plot > Disp-Pier-Top (on) 

Click Add from list 

Horizontal Axis > Time 

Type of Display 

X Axis Decimal Pt. (1)  ;  Y Axis Decimal Pt. (4) 

Type: > Time History Graph   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

圖 21. 橋墩頂部(節點 77)的歷時變位圖 

 

 

 

 


